Lords of the Fallen: Ancient Labyrinth System Requirements
Lords of the Fallen: Ancient Labyrinth is developed by CI Games. This game is released world wide by Bandai Namco Entertainment on 03 March 2015. Lords of the Fallen: Ancient Labyrinth need below system requirements graphic card 1 GB GeForce GTX 560 Ti or better / 8 GB RAM / Windows Vista(SP2)-7(SP1)-8 64-bit
Game Information
  • Developer : CI Games
  • Publisher : Bandai Namco Entertainment
  • Game category : Role Playing
  • Age Requirements : NA
  • Playing Modes : single player
  • It is released on : 03 March 2015
Lords of the Fallen: Ancient Labyrinth Minimum pc system requirements
  • Processor : Intel Core 2 Quad Q8400 2.66 GHz-AMD Phenom II X4 940 3.0 GHz
  • Ram Requirements : 6 GB RAM
  • Hard disk Space : 25 GB HDD
  • Graphic Card : graphic card 1 GB GeForce GTX 460 or better
  • Operating System : Windows Vista(SP2)-7(SP1)-8 64-bit
Lords of the Fallen: Ancient Labyrinth Recommended pc system requirements
  • Processor : Intel Core i7-3770 3.5 GHz-AMD FX-8350 X8 4.0 GHz
  • Ram Requirements : 8 GB RAM
  • Hard disk Space : 25 GB HDD
  • Graphic Card : graphic card 1 GB GeForce GTX 560 Ti or better
  • Operating System : Windows Vista(SP2)-7(SP1)-8 64-bit